You are on page 1of 49

View3D Guide

Introduction to View3D .................................................................................................................. 1


Starting Hampson-Russell Software ............................................................................................... 2
Starting View3D ......................................................................................................................... 4
A Brief Summary of the View3D Process .................................................................................. 8
Loading the Seismic and Horizon Data .......................................................................................... 8
Selection Errors ......................................................................................................................... 12
Scaling the Plot ......................................................................................................................... 14
Arranging the View ................................................................................................................... 14
Zooming .................................................................................................................................... 15
Saving the Viewing Parameters ................................................................................................ 17
Stopping This Tutorial .............................................................................................................. 18
Adding Slices ................................................................................................................................ 18
Displaying Attribute Values.......................................................................................................... 20
Changing Color Keys For Color Plots .......................................................................................... 21
Showing Traces and Color Plots Together ............................................................................... 24
Special Zoom Views ................................................................................................................. 25
Birds' Eye View .................................................................................................................... 26
Magnifying Glass Zoom ....................................................................................................... 26
Fences and Probes ..................................................................................................................... 28
Making Fences ...................................................................................................................... 29
Probes .................................................................................................................................... 30
Showing Well Log Data ................................................................................................................ 34
Selecting Which Wells to View ............................................................................................ 37
Emphasizing Value Ranges and Setting Transparency: Visual Control ....................................... 39
Removing Data From View3D ..................................................................................................... 44
Loading Data Slices as Horizons .................................................................................................. 45

View3D 1

GUIDE TO VIEW3D
Introduction to View3D
View3D is a program used to view wellbore paths, well data, seismic data and attribute data as a

three dimensional volume. The general objective is to better visualize, illustrate and spatially
analyze the data from HRS programs. This tutorial takes you through the most important options
and features of View3D.

The data set for this tutorial consists of:


A SEG-Y file, seismic.vol, which is a 3D post-stack data set.
An attribute volume, scaled_porosity.vol, which is a 3D post-stack data set.
7 wells. Each well contains a sonic log (p wave), density log, porosity log and a checkshot file.
A horizon file, Target_hrz.
Two data slices: seismic target and scaled porosity, positioned at the same place as the
horizon file.
September 2008

2 View3D

Starting Hampson-Russell Software


The first step is to start the Geoview program. Geoview is the application manager that acts as a
launch pad for other Hampson-Russell programs. If you are unfamiliar with the use of Geoview,
please refer to the Guide to GEOVIEW and eLOG documentation.
On a Unix workstation, go to a command window and type:
Geoview

<RETURN>

On a PC, click the Start button and select the Geoview option on the Programs / HRS
applications menu.
When you first launch Geoview, the first window that you see is the Opened Database List,
which displays your recently used databases. A database is identified by the extension wdb.
For this tutorial, a database has already been created for you. To load this database for the first
time, click Open to bring up the Directory Chooser.

Click the View3D folder of the HRS/data directory to bring up a list of databases in that folder.
Click the View3D.wdb item in the Available List and click OK.

September 2008

View3D 3

The Geoview Well Explorer window appears, showing the seven wells within this database. For
more on this window, see the Installation Geoview and eLOG Guide or the Geoview online help.
For now, click the X at the top right to close the window.

September 2008

4 View3D

Starting View3D
Now that the database has been opened in Geoview, we are ready to start the View3D program.
To do this, click the View3D button on the Geoview window.

The following window now appears:

September 2008

View3D 5

Note that you cannot start a new project in View3D.


The program is intended as an add-on to other HRS programs, and not as a stand-alone program.
Therefore, you would need to open a project first created in another HRS program. You can use
View3D to view any project created through these and other HRS programs.
Fortunately, we have provided a project for this tutorial.
Check the Open Existing Project button and click OK to bring up the Directory Chooser.
Click the View3DE_Guide folder in the View3D directory to show projects in the Available List.
Click the View3D_sand.prj project in the Available List and click OK.

If a message appears telling you that the pathway to the project has changed, select Switch.

September 2008

6 View3D

The View3D window now appear:


This window is used to select what data to load and unload data from the display. It will appear
like this:

Note that nothing is selected for loading.

September 2008

View3D 7

The Project Loaded column shows the available data in the selected project. If data were
missing from this list, you need to return to the original HRS program that created the project
and then load that data through that program. Then save that program. Then you would return to
View3D to display the complete data set. You can instead display seismic parameters or well
data parameters by clicking the appropriate button in the column.
The View3D Display section displays the selected data. Because no data has been selected and
plotted yet, the Display Window is black.
The Seismic Display Options section is also displayed by default and lets you select how the
seismic data is displayed: as slices, volumes or slabs.
The Toolbar lets you load data into the Display Panel, reload data from the database and create
and control slices displaying the volume.
Other sections can be brought up through the Menu, as shown below:

All of these panels can be hidden by clicking the

button at the upper left of the panel.

The Well Filter Panel lets you filter the list of wells.
The Volume Selection Panel lets you select different sources for the displayed traces, the
displayed horizon and the color plotting, as well as setting its color. The toolbar for that panel
lets you display wiggles or unload the seismic (remove it from the display).

September 2008

8 View3D

A Brief Summary of the View3D Process


In the left side of the Data window, select the data to be plotted and drag it into the display
panel.
In the right side of that window, set details for displaying.
Zoom the Display window to show the desired area.
Select the Display mode for the Display window and select what planes to show.
Set the horizon, well and seismic display parameters as needed.
Adjust the view as needed, creating new slices as required.
The geological play this tutorial handles is the same handled in the EMERGE tutorial and guide.
It is a channel sand with porosity that can be predicted from seismic data.
Loading the Seismic and Horizon Data
On the Data window, find the seismic section seismic.vol and click and drag it into the Display
Panel.
By default, the outline of the entire volume and wellbore lengths are shown, but the plot would
have extended up to 2 milliseconds and be tall and awkward to view. Therefore, we will change
the parameters before displaying the seismic data. When the program asks whether to view the
seismic parameters, select Yes to show the seismic parameters in the Data Management
column.

September 2008

View3D 9

Double-click the Domain Start field to move the value to the left. Change that value to 800 to
shorten the seismic display. We do this so that the plot will not extend above 800 milliseconds
TWT. Click Plot.
This becomes the default, or "Home" size of plot for the data, and you can return to this view by
pressing the Home key
on the vertical toolbar.

September 2008

10 View3D

Select Project Data again to show the Project Loaded list.


Find the horizon Target_hrz in the Project Loaded section. Click and drag it into the Display
Panel. It will now be plotted in that panel.
Then go to the Wells section, press the Shift button and select the top and bottom wells. All the
wells in between will also be selected. Drag these wells into the Display Panel.

September 2008

View3D 11

Now select the Selected Well bar to display that table. It shows what logs have been selected for
loading. We are missing the porosity logs. Therefore select that checkbox and reselect the
Project Data bar.

September 2008

12 View3D

A message appears, asking whether to reload the data. Select Yes.

Selection Errors
If you load an incorrect data item, select Seismic Volume>Data Selection from the View menu
to display that panel at the top of the window.

The data will be displayed as you drop it into the Display window.

September 2008

View3D 13

September 2008

14 View3D

Scaling the Plot


Your horizon may not appear exactly as shown above, and this is because the scaling may be
different. If the Time axis scale (Z) is too exaggerated, the horizon may look unreasonable. If
your Z scaling is too small, the horizon may look featureless.
From the View menu, select Advanced>3D Scale to bring up the Scaling window. Ensure that
these values are entered:
X=1
Y=1
Z=0.22
If not, then correct the values and click OK. If they are correct, then click Close.

If your plot disappears, then click the Home button


reappear with the correct scale.

on the left toolbar. Your plot will

Arranging the View


Note also that the zone of interest, the part with the horizon, is dwarfed by the spread of data.
The actual color choices for the well data, seismic and horizon will depend on what was last used
in the program. We will show how to change them later.
The entire volume is displayed with south facing upwards, contrary to what we would normally
expect, and we should keep that in mind. Reselect Show North Arrow from the
View>Advanced menu to hide that arrow.
The slices shows the porosity values that we have loaded as an attribute. They also partially
obscure the horizon, the wells and well top information (hence the clipped well top labels, which
are easier to see on the screen than on a gray-scale diagram). To move the X slice (it extends
lower left to upper right), click the slice with the left mouse button to select it. The slice now has
a red border with the edges of the volume and with any intersecting horizons or slices.
Push it to the far left. Click the Y slice and push it to the far right.

September 2008

View3D 15

Now uncheck the X and Y checkboxes at the lower left of the window. This will hide the two
seismic sections so we can concentrate on the horizon and wells. When you bring them back,
they will return in their new position at the back of the display volume.

Zooming
We will now zoom into the zone of interest.
For non-wireless three-button mouse devices:
From above the 1010 value on the left, press the middle mouse button down and drag it to about
the 1125 value on the right (see below).

September 2008

16 View3D

Note: You can use the middle mouse button to:


Shift the display around the screen:
Rotate the display around a point:
Zoom and unzoom:
Center the display around a point:

SHIFT + Middle Mouse Button


Left Mouse Button
Middle Mouse Button, hold and drag
Click Middle Mouse Button

If you do not have a middle mouse button, or if your mouse is wireless, press Page Down
several times until you get a similar magnification.

September 2008

View3D 17

Saving the Viewing Parameters


This will let you save your work and retrieve it again, which is very useful if you must interrupt
this tutorial.
From the Main menu, select View>Display>Scene. A View Parameter dialog now appears on
the right side with the Display>Scene tabs selected.

Click New to bring up the Scene Manager window. Enter a name for the scene and click OK.

Now you can bring back this exact view by reselecting View>Display>Scene, selecting the
name of the scene and clicking Load. Once you've saved a scene, the program will also ask
whether to load that scene when you restart this project.

September 2008

18 View3D

Stopping This Tutorial


First, save your scene, as described above. Either select File>Exit or close the View3D window
to close the Visual3D session.
Adding Slices
If you have stopped the program, reload the View3D program and select Yes for Reloading The
Last Scene.
Select Slice mode from the bottom left menu of the Display window, if it is not already selected.

Click the X box to display the X-axis slice as shown below:

September 2008

View3D 19

Repeat these steps for the Y slice, checking its box at the bottom left. Repeat these steps for the
Z slice, checking its box at the bottom left and then moving it to about 1100 ms, to get the
display below:

September 2008

20 View3D

Displaying Attribute Values


For View3D, attributes and seismic data are treated the same except that only seismic data can be
represented by wiggle traces. View3D can only display one "attribute" volume and one "seismic"
volume at the same time.
Click scaled_porosity.vol in the Post-stack folder of the Project Loaded section and drag it
into the display. As the display's dimensions are set by the first volume loaded (hence by the
seismic.vol volume), this volume's geometry does not affect the overall display. Therefore, you
do not need to see the seismic parameters for this volume.
There are also right-click pop-up menus in the Data window that are useful. See the online help
for more on these menus.
The Display window will now show the attribute (porosity) as a color scale and the Attribute
color key can be displayed through View>Color Volume>Color Scale.

September 2008

View3D 21

Changing Color Keys For Color Plots


We will now change the attribute color key to emphasize the higher porosity values. The default
Color Map is Rainbow, as used above.
First, select Color Scale from both the View>Seismic Volume and View>Color Volume
submenus to display the color scales.
Then, select View Parameters from the View>Color Volume submenu (either the Seismic
Volume or the Color Volume submenu) to bring up the View Parameters dialog on the right
hand side of the window.

September 2008

22 View3D

If not already selected, select Color for the Color Attribute Type.
Click the Color button to bring up the Color Scale window.
Scroll down to the Lightning color map and select it.

September 2008

View3D 23

Click OK to apply the change and close the Colormap Settings window.

Now the high porosity values are red or yellow and are easier to notice on the screen, while the
lower porosity values, in which we are not interested, are in similar shades of green and easily
ignored. Note also that the attribute data does not extend as far as the seismic, stopping at 1200,
so we can see the seismic data below as a brighter color.

September 2008

24 View3D

If the Upper and Lower values in the Color Mapping section do not approximately match our
values (-0.09 and 0.15: the negative just reflects measurement inaccuracy as the lowest possible
value should be 0.0, the 0.15 shows that the area has no high porosity), then your plot may not
resemble ours.

To change this, change the Data Minimum and Data Maximum attribute (i.e. porosity) values
respectively in the Selected Seismic Table and click Plot.
Click the X at the right top of the View Parameters panel to close it so the display panel is
wider.
To further demonstrate the porosity value, while in Slide mode
the horizon to see how the porosity map changes.

, slide the Z slice up through

Then move the Z slice back to its original position at about 1100 ms.
Showing Traces and Color Plots Together
We will now show the seismic data in a form that is not hidden by the scaled porosity colors,
essentially co-rendering the two sets of data.
Select Seismic Volume>Wiggle from the View menu. The seismic will now be displayed as
wiggle traces on top of the attribute colors.

September 2008

View3D 25

To return the seismic to its color display, reselect this menu option to turn it off.
Special Zoom Views
In the View>Color Volume menu, uncheck the Color Scale option to hide the color key. Do the
same for the Seismic Volume menu. At the bottom of the window, uncheck the Y and Z
checkboxes, so only the X plane is left.
These steps will unclutter the view.

September 2008

26 View3D

Birds' Eye View


Press <SHIFT-HOME> on the keyboard to use this feature. A view of the entire volume will be
displayed in the upper right corner. This view will match the orientation of the current view.
Press <SHIFT-HOME> on the keyboard again to close the birds' eye view.

Magnifying Glass Zoom


Click the Magnify button
feature.

September 2008

on the left side or press <M> (or m) on the keyboard to use this

View3D 27

Note: The Display Window must be active for this to work. If you are doing this tutorial by
using a pdf file on a screen, you may have that screen active when you press <M> and then
nothing happens. In that case, click on the Display Window to activate it and repress <M>.
A square appears in the middle of the view, magnifying the zone behind it. This magnifying
glass now moves with the mouse. You can still use the middle mouse button for zooming or the
left button for moving slices while this feature is up. You can also make this square wider or
smaller with <CTRL-PAGEUP> and <CTRL-PAGEDOWN>. Press <M> or click
turn it off.

again to

September 2008

28 View3D

Fences and Probes


Now we will show alternative ways to display parts of the volume. First, uncheck the X
checkbox to remove that plane (clearing the display except for the horizon) and click Home
once so the top of the volume is visible.

On the right side of the window, we have the Slice Mode buttons.

September 2008

View3D 29

Making Fences
A fence is a series of slices connected end-to-end, resembling a fence (of course). They can be
very useful to follow channels, bars or reefs, or to outline a property of land.
To create a fence, click the Fence icon . Then click the front left side to start the fence (you
must click on the top plane, not on the side).

Click the end of that fence panel on the front right side. Now click in a direction to the upper
right. Click further right and then click to the lower right. See below.

Then click the Slide icon


to leave Fence mode and therefore finish that fence. In other
words, you enter Fence mode, click the corners of each fence section and then exit Fence mode
to create a fence.
Once you have created a fence, you can move its segments around in Slide mode by dragging
the corners.
In the following example, the fence created above was moved to match the target channel. Note
how it also emphasizes the horizon structure.

September 2008

30 View3D

Now click the Delete Slice icon (the box with the X, ) and select one part of the fence to
remove the entire fence. Remember to then select Slide, so you do not stay in Delete mode.
Probes
A probe is an orthogonal shape that shows the attribute or seismic in a different way than slices.
While slices must extend the entire height of the volume, probes can be limited just to an area of
interest, making them ideal for screen captures. You can also create inside angles (which
resembles "steps" in the probe).
Since we do not need the entire volume for probes, click the Zoom In
button twice. If
necessary, press <SHIFT> and move the mouse, holding the middle button down, until the
Target_hrz horizon is in the middle of the display.
Click the X checkbox at the bottom to add that slice. From the View>Probe menu, select Add
Probe. The initial orthogonal shape is added automatically.

September 2008

View3D 31

To adjust the probe, click exactly on an edge to create a red line. Then drag that edge.

September 2008

32 View3D

Now we will add a corner reentrant. Click precisely on the foremost upper corner. The probe
now has a cut-in section.

Click an edge of the horizontal part of this reentrant and slide it downwards towards the horizon.
September 2008

View3D 33

When you are finished, select Delete current Probe or Delete all probe from the Probe menu
to remove the probe display. Uncheck the X checkbox at the bottom.

September 2008

34 View3D

Showing Well Log Data


First zoom out with the Page Down key to see the top of the volume. Then select View>Well>
Show Annotation to display the well names at the top of the plot and the top names on the
wells.

Zoom back into the horizon section. Select Well>View Parameters from the View menu to
bring that dialog up on the right hand side.

September 2008

View3D 35

The Top Disk is the marker that indicates a top on the wellbore. The Thickness value refers to
the thickness of the top disks. The Well Bore refers to the thickness of the actual hole outline in
the display.
Select the Show checkbox. Select Porosity for the Center Cylinder tab.

September 2008

36 View3D

Enter the following parameters (if not already set), so the center porosity plot is easier to see:
Well Bore = "0.5".
Top Disk = "2".
Variable Radius selected from the Appearance box.

Keep the other parameters the same. Below is the result. Note how the radius changes to match
the density values.

September 2008

View3D 37

Below is an example where the density log was plotted on the left side and nothing plotted in the
center. The Well Annotation has been turned on.

Selecting Which Wells to View


From the View menu, select Well>Well List to bring up the Well List Dialog. In the Well ID
column, use <SHIFT> and the mouse to select all the wells except 16-08. Click Unload. Then
click OK.

September 2008

38 View3D

Now only the 16-08 well is displayed.

September 2008

View3D 39

Emphasizing Value Ranges and Setting Transparency: Visual Control


Check the X and Y checkboxes at the bottom of the Display window to show those slices.
Position them once again at the back of the volume (they should be there automatically if you
have not moved them).

If the View Parameters dialog is not still up, bring it up through View>Seismic Volume>View
Parameters. Select the Volume tab.
Select the Color radio button at the top of that dialog for the Scaled Porosity attribute viewing
parameters.

September 2008

40 View3D

Unselect the Freehand checkbox and select the Linear check box. Click on the middle red dot at
the left side of the upper box. Then drag this toward the right, bringing a vertical line along, to
about 3/4 over. The Auto Apply box should be on by default.

September 2008

View3D 41

What this means is that all the values whose colors fit under the now dark section will not be
displayed on the plot. Therefore, only the high porosity areas will be colored. The low porosity
values will not appear. Also, the underlying seismic data will be easier to see.
However, as it is also colored, we have difficulty distinguishing it from the attribute. We could
turn it off using the Volume Selection window (View>Seismic Volume>Data Selection and
unselect the Seismic checkbox), but then we have no seismic. Instead, we will change the color
key for the seismic.

Now check the Seismic radio button, and click the Color button to bring up a Color Key
window. Scroll up the list and select Gray Scale. Click OK. Now the seismic data is easily
distinguished from the attribute data.

September 2008

42 View3D

Now we will change the Visual parameters for the seismic. Do not uncheck the Freehand
checkbox this time. Now draw a curve from the lower left to the upper right, such as below.

Now the seismic peaks are emphasized.

September 2008

View3D 43

For the Display mode, now select Volume instead of Slice.

The entire seismic and attribute volumes are now displayed.

Now, from the View>Seismic Volume menu, unselect Show Seismic to remove the seismic
data from the display. Now only the attribute data (i.e., higher density) is shown. Note that it may
take a few seconds to replot.

September 2008

44 View3D

By selecting to show only the end values, we can highlight anomalies.

Removing Data From View3D


At the bottom left of the window, reselect Slice instead of Volume for the Display mode. Turn
the X, Y and Z slices off.
Hide the displayed well through the Well List window by selecting the well, clicking Unload
and OK, as before.
If not up, bring up the Volume Selection panel (View>Seismic Volume>Data Selection).
Click the Trash Can button
to the right of the Color Volume's Color Key field.

This will unload the attribute plot, leaving only the seismic, well and horizon data. We could
have instead hidden the attribute plot without removing it by unselecting the checkbox to the left
of Color Volume.

September 2008

View3D 45

Loading Data Slices as Horizons


Now we will load a Data Slice based on the Target_hrz horizon. In the Data Slice section of the
Project Loaded column, there are two data slices. The slice seismic target is just a sparsersampled version of the Target_hrz horizon, and we will not use it. It, however, was used in
EMERGE to create another slice, the scaled_porosity slice. This slice will display porosity
calculated by the EMERGE program. Click and drag it into the display.
Open the View Parameters section again and select the Surface tab.

Highlight only scaled_porosity and click Apply.


The Display window will show the same amplitude surface as Target_hrz, but as the sampling
rate was lower, it is not as smoothed as the first horizon we used. The color plot will now
represent scaled porosity, not two-way time. In this display, we have turned the Horizon Color
Key legend on through View>Surface>Color Scale.

Not
e
that
blue
and
viol
et
repr
ese
nt
mo
Green and blue represent moderate porosity and yellow and red represent insufficient porosity.
Click the Wire Frame check box in the Show section.

September 2008

46 View3D

Then click Apply.

September 2008

View3D 47

The wire frame matches the TWT data and shows the effect of the sampling rate. By the way,
this is a good surface to try the Magnifying Glass view we talked about earlier (as brought up by
the M key).
Uncheck Wire Frame and check the Contour box.

Then click Apply.

These contours reflect the TWT structure. You can set different contour parameters by clicking
the Options button to bring up the Horizon Contour Settings dialog.
When you have finished, close the window or select File>Exit.
This concludes the Visual3D tutorial.

September 2008